Good Sam Club Open Roads Forum: Search
Open Roads Forum Already a member? Login here.   If not, Register Today!  |  Help

Newest  |  Active  |  Popular  |  RVing FAQ Forum Rules  |  Forum Posting Help and Support  |  Contact  



Open Roads Forum  >  Search the Forums

 > Your search for posts made by 'FULL-THROTTLE' found 4 matches.

Sort by:    Search within results:
  Subject Author Date Posted Forum
RE: New Camper problems

I am thinking of putting two 800cca optima rv batteries wired in parallel, does any one else do this?
FULL-THROTTLE 03/22/20 12:40pm General RVing Issues
RE: New Camper problems

First of all I want to say thank you all for your input, I did remover the battery a second time and it shows 30% full, and when it was in the rv and not in use, (120v house fed extension cord), the master key was off. SSOOOO it has to be the battery. The rv dealership is limited on staff due to this **** virus, Im not sure I want to go into their building till things settle down. I will keep you updated. Thanks Again, Fran
FULL-THROTTLE 03/22/20 11:43am General RVing Issues
RE: New Camper problems

I tried closing awning and slide out and it did not move, but when I put jumper cables from truck battery to the camper battery everything works? I am looking for a wiring diagram for this if anyone has one. I will get the battery tomorrow
FULL-THROTTLE 03/21/20 07:30pm General RVing Issues
New Camper problems

I need some help with my new 2020 Cougar 26RBS, When it was plugged into the rv stores 240v plug everything worked perfectly, I drive it home and nothing works, I plugged a 120v from and outside of my house outlet to the 25ft cable, now I get lights and tv and refrigerator. I pulled the brand new battery and put it on my charger and it was completely dead. So I connect jumper cables from my truck to the battery cable on the rv and everything works, slide, fridge, awning so assume I have let the battery charge overnight. I put it back in the rv and again nothing, I put the jumper cables to the rv battery and everything comes alive I don't get it I assumed with 120v from the house it would run the slide and awning. What am I missing here? Thank you, Fran
FULL-THROTTLE 03/21/20 06:44pm General RVing Issues
Sort by:    Search within results:


New posts No new posts
Closed, new posts Closed, no new posts
Moved, new posts Moved, no new posts

Adjust text size:




© 2020 CWI, Inc. © 2020 Good Sam Enterprises, LLC. All Rights Reserved.