Good Sam Club Open Roads Forum: Search
Open Roads Forum Already a member? Login here.   If not, Register Today!  |  Help

Newest  |  Active  |  Popular  |  RVing FAQ Forum Rules  |  Forum Posting Help and Support  |  Contact  



Open Roads Forum  >  Search the Forums

 > Your search for posts made by 'ginaseven' found 1 matches.

Sort by:    Search within results:
  Subject Author Date Posted Forum
Class C Battery issues

Guidance needed.... I just came home from my 3rd trip with my new to me 2013 Coachman Leprechaun Class C. The first trip all went well until I was packing up to leave and could not get the slides to retract. After checking everything I could think of, I realized that the main battery disconnect was turned to Off. Turned it on and slides came in without an issue. I took the coach battery to NAPA when I got home bc it did not have a charge, and would not charge. They charged it and tested it and said it was fine. Trip 2...Initially the water heater would not come on in gas or electric, after a few seconds the DSI fault light came on. I tried it a few times a day and on day 3 it came on in the Electric mode. Trip 3...The water heater never came on in either mode. After camping for 5 days, getting ready to pull out and the RV won't start, the motor battery is dead. I got a jump and it started right up. I figured I inadvertently left something on that drained the battery. (new battery in 2019) I drove about 2 hrs to a Flying J to dump. I turned the RV off (sure that 2 hours was enough to charge the battery) This took about 15 mins, when I went to leave and of course it would not start again. Where should I start? Replace the House battery? The motor battery? None of the above :) Thanks as always for your expertise!!
ginaseven 05/27/20 03:53pm Tech Issues
Sort by:    Search within results:


New posts No new posts
Closed, new posts Closed, no new posts
Moved, new posts Moved, no new posts

Adjust text size:




© 2020 CWI, Inc. © 2020 Good Sam Enterprises, LLC. All Rights Reserved.