Good Sam Club Open Roads Forum: Class A Motorhomes: 4-way Flashers not working
Open Roads Forum Already a member? Login here.   If not, Register Today!  |  Help

Newest  |  Active  |  Popular  |  RVing FAQ Forum Rules  |  Forum Posting Help and Support  |  Contact  

Search:   Advanced Search

Search only in Class A Motorhomes

Open Roads Forum  >  Class A Motorhomes  >  All

 > 4-way Flashers not working

Reply to Topic  |  Subscribe  |  Print Topic  |  Post New Topic  | 
Page of 2  
Prev
MrWizard

Traveling

Moderator

Joined: 06/27/2004

View Profile



Posted: 03/12/20 10:42am Link  |  Quote  |  Print  |  Notify Moderator

Vehicles used to have discreet individual switches for each function,
Now it's one multi function .... Multi contacts. Switch
Push in, pull out, fwd backward, up down
Each action operated different contacts
Only one set of wires going to the lights
The switch contacts choose which wires are hot giving power to the different functions


Radiate The Happy
....

Connected using Verizon and AT&T
1997 F53 Bounder 36s


carringb

Corvallis, OR

Senior Member

Joined: 07/28/2003

View Profile


Offline
Posted: 03/12/20 10:50am Link  |  Quote  |  Print  |  Notify Moderator

drifterpilot wrote:


When I step on the brakes, both turn signals on the dash illuminate and stay illuminated as long as I stay on the brakes.


This is the normal function for the GM multi-function switch in your coach. All GM trucks with combined stop/turn lights over-ride the 4-ways with the brake light. This made sense prior to center-mount brake lights becoming prevalent.


Bryan

2000 Ford E450 V10 VAN! 450,000+ miles
2014 ORV really big trailer
2015 Ford Focus ST


Branson N Tucson

Tn

Full Member

Joined: 05/09/2012

View Profile



Good Sam RV Club Member

Offline
Posted: 03/12/20 12:31pm Link  |  Quote  |  Print  |  Notify Moderator

Not sure with your RV but my Providence DP has individual fuses for each IE. Turn Signals, flashes, brakes.
They are located in same apartment buy batteries.

drifterpilot

Gloucester, Virginia

Senior Member

Joined: 03/17/2002

View Profile



Good Sam RV Club Member

Offline
Posted: 03/12/20 02:29pm Link  |  Quote  |  Print  |  Notify Moderator

Problem figured out - not solved yet, but know why!

The Hazard 4-Way Flashers Light Switch (Off/On) is faulty. When I push the switch to "On", nothing happens. But when I "lean" the switch slightly to the left, the Hazard 4-Way Flashers start flashing audibly and visually on the dash.

The switch body is recessed beneath a two-piece protective cover. I have to remove the top half of the cover to get to the switch body. The top half of the cover encircles the ignition switch and cannot be lifted until I remove the top part of the switch. The top part of the ignition switch is what you twist with your thumb and trigger finger when you are turning the key.

How do I get that switch apart?

Thanks.


2003 Winnebago Adventurer 33V
112,000 miles
Workhorse W20
Vortec 8.1, Allison 1000
Kingdome (in-motion tracking)
Bilstein shocks (installed July 2013)
Safe-T-Plus Steering Stabilizer
Blue Ox Adventa II and KarGuard
Brake Buddy
2019 Chevrolet Colorado LT 4-Wheel Dr


allbrandauto

maryland

Senior Member

Joined: 09/19/2013

View Profile



Good Sam RV Club Member

Offline
Posted: 03/12/20 04:31pm Link  |  Quote  |  Print  |  Notify Moderator

its part of the turn signal switch napa part #dl6092 with cruise control

Reply to Topic  |  Subscribe  |  Print Topic  |  Post New Topic  | 
Page of 2  
Prev

Open Roads Forum  >  Class A Motorhomes  >  All

 > 4-way Flashers not working
Search:   Advanced Search

Search only in Class A Motorhomes


New posts No new posts
Closed, new posts Closed, no new posts
Moved, new posts Moved, no new posts

Adjust text size:




© 2020 CWI, Inc. © 2020 Good Sam Enterprises, LLC. All Rights Reserved.