Good Sam Club Open Roads Forum: Running norcild 1200 off the alternator
Open Roads Forum Already a member? Login here.   If not, Register Today!  |  Help

Newest  |  Active  |  Popular  |  RVing FAQ Forum Rules  |  Forum Posting Help and Support  |  Contact  

Search:   Advanced Search

Search only in Class A Motorhomes

Open Roads Forum  >  Class A Motorhomes  >  General Topics

 > Running norcild 1200 off the alternator

Reply to Topic  |  Subscribe  |  Print Topic  |  Post New Topic  | 
Page of 2  
Prev
theoldwizard1

SE MI

Senior Member

Joined: 09/07/2010

View Profile


Offline
Posted: 05/31/20 11:08am Link  |  Quote  |  Print  |  Notify Moderator

islandvagabonds wrote:

I have occasionally run the fridge on inverter while driving at high altitudes. The 425 watt heaters should draw about 45amps at 12 volts. Adding 10 to 15 amps for chassis demands total altrnatorload should be 60+-. The alternator on the cat diesel is supposedly rated to 160amps.

No that alternator should handle it just fine.

Why did you come to the conclusion the alternator is bad ? Low voltage ? If so, it is either the diodes of the voltage regulator inside of the alternator. If you are handy enough to replace and alternator, you are handy enough to replace the voltage regulator.

The rest of the major parts (bearing, slip rings, brushes, windings) in an alternator last a long, LONG.

wolfe10

Texas

Senior Member

Joined: 10/08/2000

View Profile


Offline
Posted: 05/31/20 12:14pm Link  |  Quote  |  Print  |  Notify Moderator

Have also seen bad battery isolators diagnosed as bad alternators.

Same for broken "sense wire"

Bottom line is diagnose the root cause!


Brett Wolfe
Ex: 2003 Alpine 38'FDDS
Ex: 1997 Safari 35'
Ex: 1993 Foretravel U240


FMCA Forum: www.community.fmca.com/index

Diesel RV Club:http://www.dieselrvclub.org/

islandvagabonds

Ontario

Full Member

Joined: 09/06/2009

View Profile



Good Sam RV Club Member

Offline
Posted: 05/31/20 04:15pm Link  |  Quote  |  Print  |  Notify Moderator

The shop ran new wires from the alt B÷ to the chassis batt and the pos side of the starter solenoid. Also new ground wires to the chassis ground post and the neg chassis batteries. A bit of overkill but everything works and I do like redundancy.
The failure was total, no output. I am starting to think the wiring may have been the issue to start with.
Thanks for all your comments. We all learn on the forum which makes it a wonderful resource for all of us.

Keep well my friends!
Bob

Reply to Topic  |  Subscribe  |  Print Topic  |  Post New Topic  | 
Page of 2  
Prev

Open Roads Forum  >  Class A Motorhomes  >  General Topics

 > Running norcild 1200 off the alternator
Search:   Advanced Search

Search only in Class A Motorhomes


New posts No new posts
Closed, new posts Closed, no new posts
Moved, new posts Moved, no new posts

Adjust text size:




© 2020 CWI, Inc. © 2020 Good Sam Enterprises, LLC. All Rights Reserved.