Good Sam Club Open Roads Forum: Water pump runs but no water pressure
Open Roads Forum Already a member? Login here.   If not, Register Today!  |  Help

Newest  |  Active  |  Popular  |  RVing FAQ Forum Rules  |  Forum Posting Help and Support  |  Contact  

Search:   Advanced Search

Search only in Tech Issues

Open Roads Forum  >  Tech Issues

 > Water pump runs but no water pressure

Reply to Topic  |  Subscribe  |  Print Topic  |  Post New Topic  | 
bigorange

Tucson, AZ

Senior Member

Joined: 04/19/2013

View Profile



Good Sam RV Club Member

Offline
Posted: 06/15/20 12:01am Link  |  Quote  |  Print  |  Notify Moderator

Posting this here in case it helps someone else with a similar issue. On our last outing we found the water pump didn’t work en route...could hear the pump running but no pressure. Luckily we had water hookup at our destination so it wasn’t a huge issue. One of the faucets had a sediment clog That I cleared on the same trip so I thought the pump might be clogged as well.

Today I had a chance to troubleshoot and fixed it...half the time was spent accessing the water pump since Forest River decided to install it behind our fireplace. After clearing the screen filter of the little bit of sediment and confirming all the lines were fine I took the pump apart since I’ve read before that sediment and other debris inside the pump can affect performance. There was a spring loaded check valve (I assume that’s what it is) stuck in the closed position so water would not flow through the pump. After freeing the valve and re-assembling the pump everything works fine.


Not all those who wander are lost. - Tolkien

2018 Cherokee 235B 5W
2011 Ram 2500 CC SWB SLT 4WD 6.7 CTD 3.73
B&W Turnover Ball + Companion Slider hitch
2003 Sierra T22 TT - Sold


MEXICOWANDERER

las peñas, michoacan, mexico

Senior Member

Joined: 06/01/2007

View Profile


Offline
Posted: 06/15/20 12:58am Link  |  Quote  |  Print  |  Notify Moderator

Fixing something rather than replacing it gives a person a good feeling. Kudos.

jdc1

Rescue, Ca

Senior Member

Joined: 05/30/2011

View Profile


Offline
Posted: 06/15/20 01:00am Link  |  Quote  |  Print  |  Notify Moderator

MEXICOWANDERER wrote:

Fixing something rather than replacing it gives a person a good feeling. Kudos.


Ditto

Putting that $100/hour cost savings in my pocket feels good too.

* This post was edited 06/15/20 01:14am by jdc1 *

rrupert

NW PA

Senior Member

Joined: 02/26/2005

View Profile


Offline
Posted: 06/15/20 06:55am Link  |  Quote  |  Print  |  Notify Moderator

Not using the pump for an extended period of time can allow the parts to dry out and stick, I guess, causing the pump to not prime. I got a new Shurflo pump and it had water in it. I suppose it was for that reason.


Rich and Joyce
2018 Jayco Jay Flight 21QB
2012 Ford F150 4X4 Supercrew EcoBoost
Reese Strait-Line Dual Cam Hitch
Amateur Radio K3EXU


Reply to Topic  |  Subscribe  |  Print Topic  |  Post New Topic  | 

Open Roads Forum  >  Tech Issues

 > Water pump runs but no water pressure
Search:   Advanced Search

Search only in Tech Issues


New posts No new posts
Closed, new posts Closed, no new posts
Moved, new posts Moved, no new posts

Adjust text size:




© 2020 CWI, Inc. © 2020 Good Sam Enterprises, LLC. All Rights Reserved.