Good Sam Club Open Roads Forum: Tech Issues: Electrical issues
Open Roads Forum Already a member? Login here.   If not, Register Today!  |  Help

Newest  |  Active  |  Popular  |  RVing FAQ Forum Rules  |  Forum Posting Help and Support  |  Contact  

Search:   Advanced Search

Search only in Tech Issues

Open Roads Forum  >  Tech Issues

 > Electrical issues

Reply to Topic  |  Subscribe  |  Print Topic  |  Post New Topic  | 
smiledr

Porterville, CA

Full Member

Joined: 04/19/2004

View Profile





Offline
Posted: 08/07/20 04:24pm Link  |  Quote  |  Print  |  Notify Moderator

2015 Itasca Navion 24G Woke up this morning and half of the outlets don’t work and neither does the TV. The micro works and all the lights work. I found a gfi in the bath and in basement storage that I reset. I reset circuit breakers. Reset breaker at shore power hook up. Still nothing. The outlets in the bath and kitchen work but not bedroom or near sofa and TV doesn’t work. What am I missing?


smiledr

2oldman

NM

Senior Member

Joined: 04/15/2001

View Profile


Offline
Posted: 08/07/20 04:29pm Link  |  Quote  |  Print  |  Notify Moderator

If 50a service you're missing one leg.

smiledr

Porterville, CA

Full Member

Joined: 04/19/2004

View Profile





Offline
Posted: 08/07/20 04:31pm Link  |  Quote  |  Print  |  Notify Moderator

No we are 30a

Lynnmor

Red Lion

Senior Member

Joined: 07/16/2011

View Profile



Good Sam RV Club Member


Posted: 08/07/20 05:07pm Link  |  Quote  |  Print  |  Notify Moderator

Tighten connections in the breaker box. Outlets are daisy chained using those cheap self contained devices, perhaps you have a bad connection there. If you can find an outlet that will still works, but can be switched off with the breaker, start there. Also, pull GFCI that controls that circuit and check it.





opnspaces

San Diego Ca

Senior Member

Joined: 12/22/2004

View Profile


Offline
Posted: 08/07/20 05:47pm Link  |  Quote  |  Print  |  Notify Moderator

Is there a GFCI in the outside outlet to plug things into when under the awning? Maybe that one is tripped.


2001 Suburban 4x4. 6.0L, 4.10 3/4 ton
2005 Jayco Jay Flight 27BH
1986 Coleman Columbia Popup.

wa8yxm

Wherever I happen to park

Senior Member

Joined: 07/04/2006

View Profile


Offline
Posted: 08/07/20 05:55pm Link  |  Quote  |  Print  |  Notify Moderator

True story: man came to me with a very nice high end Motor home and the exact same issue you have.

I ask him if he had an inverter (he did not know) well let's look
First door he opened was batteries
next was the inverter
Flipped the breaker from Tripped/off to back on and said 'Go check'
He went in and his wife ask "Does he think he can help"
Husband answered "he's already fixed it"

Suggest you check for an inverter
Breakers may be on inverter (his were very easily found sometimes they are in back) may be flip type may be push in to reset.

May also be a 2nd breaker box somewhere (That's my rig)


Home is where I park it.
2005 Damon Intruder 377 Alas declared a total loss
after a semi "nicked" it. Still have the radios
Kenwood TS-2000, ICOM ID-5100, ID-51A+2, ID-880 REF030C most times


smiledr

Porterville, CA

Full Member

Joined: 04/19/2004

View Profile





Offline
Posted: 08/07/20 07:29pm Link  |  Quote  |  Print  |  Notify Moderator

Fixed it. I reset the gfi for the third time. Thanks for the help

Camreal

Kerrville, Tx

Senior Member

Joined: 06/04/2012

View Profile



Good Sam RV Club Member

Offline
Posted: 08/08/20 04:17am Link  |  Quote  |  Print  |  Notify Moderator

GFI can be a problem. Years ago I had one that would not reset because of small water leak.

Reply to Topic  |  Subscribe  |  Print Topic  |  Post New Topic  | 

Open Roads Forum  >  Tech Issues

 > Electrical issues
Search:   Advanced Search

Search only in Tech Issues


New posts No new posts
Closed, new posts Closed, no new posts
Moved, new posts Moved, no new posts

Adjust text size:




© 2021 CWI, Inc. © 2021 Good Sam Enterprises, LLC. All Rights Reserved.