Good Sam Club Open Roads Forum: Tow Vehicles: Truck not getting fuel
Open Roads Forum Already a member? Login here.   If not, Register Today!  |  Help

Newest  |  Active  |  Popular  |  RVing FAQ Forum Rules  |  Forum Posting Help and Support  |  Contact  

Search:   Advanced Search

Search only in Tow Vehicles

Open Roads Forum  >  Tow Vehicles

 > Truck not getting fuel

Reply to Topic  |  Subscribe  |  Print Topic  |  Post New Topic  | 
Page of 4  
Prev  |  Next
Thunderbolt

North Branch, Mn USA

Senior Member

Joined: 07/03/2003

View Profile


Offline
Posted: 09/28/21 08:06am Link  |  Quote  |  Print  |  Notify Moderator

enblethen wrote:

Have you thought about a bad fuel pressure regulator?


It is all fixed now, but yes I had thought about the regulator and pulled the fuel line off leading to it and still did not get fuel. That is when I realized the pump wasn't even running.


Bryan
2003 2500HD Ext. cab short box
6.0 liter 4.10 gears, Nelson performance PCM 293,000 miles
98 K1500 4x4 heavy duty 1/2 ton (Sold)
6,600lb GVWR 5,280lbs on the scale empty
14 bolt rear diff. 3:73 , Tranny and oil coolers
380,000 miles.

wowens79

Georgia

Senior Member

Joined: 01/05/2015

View Profile


Offline
Posted: 09/28/21 11:22am Link  |  Quote  |  Print  |  Notify Moderator

The fuel pump is the only thing on my 6.0 that has left me on the side of the road. It died at 195k 6 miles from the campsite. It's now at 256k, and still going strong.


2002 Chevy Silverado 1500HD 6.0l 241k miles and climbing
2016 Heritage Glen 29BH
2003 Flagstaff 228D Pop Up

Thunderbolt

North Branch, Mn USA

Senior Member

Joined: 07/03/2003

View Profile


Offline
Posted: 09/29/21 07:43am Link  |  Quote  |  Print  |  Notify Moderator

wowens79 wrote:

The fuel pump is the only thing on my 6.0 that has left me on the side of the road. It died at 195k 6 miles from the campsite. It's now at 256k, and still going strong.

The only thing that left me stranded besides the fuel pump was the transmission and that was likely my fault.

I have a Nelson Performance PCM in the truck with shift points raised and firmed up as well as the engine tuning. I went to go around a semi near my house that was barley moving and I let the truck shift from 1st to 2nd gear at WOT and it happened. I heard a loud bang and then nothing. I had no forward gears or reverse and the truck acted like it was in neutral. I thought the input shaft broke, but it stripped all the splines out of the forward drum.

Thunderbolt

North Branch, Mn USA

Senior Member

Joined: 07/03/2003

View Profile


Offline
Posted: 10/07/21 04:04pm Link  |  Quote  |  Print  |  Notify Moderator

UPDATE. I thought I had this truck fixed and the fuel issue is, however it died again ! Fuel pressure is good so I went to check spark. I unplugged a wire and put a spark plug in the wire so I could check. I held it to the exhaust manifold and had my wife cranking it over. At first there was no spark and then there were a couple sparks and the truck started and has been running for half an hour. I wish it would not have started ! I am now thinking I have a ground issue for the coils, but unsure and I will not drive this until I know I found a problem. Any suggestions ? I don't like giving up, but am at the point of having a shop look at it, but how are they going to diagnose it when it actually runs at the time ? I put 300 miles on since replacing the pump and not one issue until today.

Thunderbolt

North Branch, Mn USA

Senior Member

Joined: 07/03/2003

View Profile


Offline
Posted: 10/07/21 04:08pm Link  |  Quote  |  Print  |  Notify Moderator

Would a crankshaft position sensor cause this even if the check engine light is not on ?

enblethen

Moses Lake, WA

Senior Member

Joined: 01/05/2005

View Profile






Posted: 10/07/21 06:53pm Link  |  Quote  |  Print  |  Notify Moderator

Camshaft position sensor.
Both camshaft and crankshaft sensor should throw a code.
I am still thinking oil pressure sending unit. When first turning key on pump is powered for 10-15 seconds through the fuel pump relay. Then if oil pressure is present power to the pump is through oil pressure sending unit.


Bud
USAF Retired
Pace Arrow

2003 Chev Ice Road Tracker


Thunderbolt

North Branch, Mn USA

Senior Member

Joined: 07/03/2003

View Profile


Offline
Posted: 10/08/21 06:25am Link  |  Quote  |  Print  |  Notify Moderator

enblethen wrote:

Camshaft position sensor.
Both camshaft and crankshaft sensor should throw a code.
I am still thinking oil pressure sending unit. When first turning key on pump is powered for 10-15 seconds through the fuel pump relay. Then if oil pressure is present power to the pump is through oil pressure sending unit.


I am no longer having fuel issues though. The fuel pump is working and I have fuel pressure, but now I have intermittent no spark. I have been reading about bad grounds for the coil packs that are supposed to be a common issue. The trouble is that now the truck starts fine, but I won't drive it this way. Would the oil pressure switch affect spark ?

enblethen

Moses Lake, WA

Senior Member

Joined: 01/05/2005

View Profile






Posted: 10/08/21 07:22am Link  |  Quote  |  Print  |  Notify Moderator

My old GM manual says yes, no oil oil pressure no spark! It is old and does not cover multi-port injection, only TBI.

Thunderbolt

North Branch, Mn USA

Senior Member

Joined: 07/03/2003

View Profile


Offline
Posted: 10/08/21 05:06pm Link  |  Quote  |  Print  |  Notify Moderator

New UPDATE.
I found the problem ! Truck did not start when I got home so I pulled the harness connector that goes to the coil packs on the drivers side. I hooked a test light to the positive side of the battery and tested the ground in the connector and the light was dim so I jiggled the ground wire near the power steering pump and the light was bright. Truck started right up and while it was running I jiggled the wire and the truck died. I confirmed it several times. I could move the wire and it would start and if I moved it again it would die. Bottom line is it is a partially broken ground wire.

enblethen

Moses Lake, WA

Senior Member

Joined: 01/05/2005

View Profile






Posted: 10/08/21 08:31pm Link  |  Quote  |  Print  |  Notify Moderator

Thanks for update!

Reply to Topic  |  Subscribe  |  Print Topic  |  Post New Topic  | 
Page of 4  
Prev  |  Next

Open Roads Forum  >  Tow Vehicles

 > Truck not getting fuel
Search:   Advanced Search

Search only in Tow Vehicles


New posts No new posts
Closed, new posts Closed, no new posts
Moved, new posts Moved, no new posts

Adjust text size:




© 2021 CWI, Inc. © 2021 Good Sam Enterprises, LLC. All Rights Reserved.