Good Sam Club Open Roads Forum: Truck Campers: Jack Misbehaving
Open Roads Forum Already a member? Login here.   If not, Register Today!  |  Help

Newest  |  Active  |  Popular  |  RVing FAQ Forum Rules  |  Forum Posting Help and Support  |  Contact  

Search:   Advanced Search

Search only in Truck Campers

Open Roads Forum  >  Truck Campers

 > Jack Misbehaving

Reply to Topic  |  Subscribe  |  Print Topic  |  Post New Topic  | 
Page of 2  
Next
rutzbeck

Haines, AK

Full Member

Joined: 08/13/2009

View Profile





Offline
Posted: 10/20/21 03:46pm Link  |  Quote  |  Print  |  Notify Moderator

So yesterday I am in the process of unloading my camper and of course I'm at the highest it needs to go, when one rear jack stops working. It wasn't making any sound. I managed to complete the unloading process by stopping every so often and manually working the jack. After I got it down I checked the fuses in the camper. The Left rear jack's fuse looked alright but I switched to the Right rear and then put the Right rear's in the left rear. Both jacks worked. So why didn't it work earlier. Any idea's.

Kayteg1

California > Nevada

Senior Member

Joined: 06/18/2015

View Profile


Offline
Posted: 10/20/21 04:03pm Link  |  Quote  |  Print  |  Notify Moderator

Dirty fuse connectors?





rutzbeck

Haines, AK

Full Member

Joined: 08/13/2009

View Profile





Offline
Posted: 10/20/21 06:37pm Link  |  Quote  |  Print  |  Notify Moderator

It doesn't look like it. The cover was in place and it looked pretty clean. I was wondering if it could be a sign that the fuse was about to go.

I replaced the board and remote a year and half ago. It is a happijak 4800. The jacks were replaced 3 years ago. The motor on that side is older.

jimh425

Western MT

Senior Member

Joined: 06/11/2006

View Profile





Offline
Posted: 10/20/21 08:33pm Link  |  Quote  |  Print  |  Notify Moderator

I have a rear one that acts up from time to time. I don’t know why, but usually it’s during retracting.


'10 Ford F-450, 6.4, 4.30, 4x4, 14,500 GVWR, '06 Host Rainer 950 Dbl Slide, Torklift Talon tiedowns, Glow Steps, and Fastguns. Bilstein 4600s, Firestone Air Bags, Toyo M655 225/19.5 Gs, Curt front hitch, Energy Suspension bump stops.


mkirsch

Rochester, NY

Senior Member

Joined: 04/09/2004

View Profile



Posted: 10/21/21 06:21am Link  |  Quote  |  Print  |  Notify Moderator

If switching the fuses around made it work I would suspect dirty connections. Even if they don't "look" dirty.


Putting 10-ply tires on half ton trucks since aught-four.

Bedlam

PNW

Moderator

Joined: 06/13/2012

View Profile



Good Sam RV Club Member


Posted: 10/21/21 07:52am Link  |  Quote  |  Print  |  Notify Moderator

Your fuse may also have a hairline crack that was pushed back together when reseating it. I had a batch of glass fuses that let go inside the end cap and would show good until you put a load on them - The same can happen in the plastic modular style.


Chevy Sonic 1.8-Honda Passport C70B-Host Mammoth 11.5-Interstate Car Carrier 20-Joyner SandViper 250-Kawasaki Concours ZG1000-Paros 8' flatbed-Pelican Decker DLX 8.75-Ram 5500 HD-Tank Urban Touring 150SE-VW TransBuggy 1200


rutzbeck

Haines, AK

Full Member

Joined: 08/13/2009

View Profile





Offline
Posted: 10/21/21 10:39am Link  |  Quote  |  Print  |  Notify Moderator

I'll clean it and change the fuse. Should I do anything other than can air to clean it?

ticki2

NH

Senior Member

Joined: 07/09/2008

View Profile



Posted: 10/21/21 11:19am Link  |  Quote  |  Print  |  Notify Moderator

Electronics cleaner and dielectric grease at you favorite auto store


'68 Avion C-11
'02 GMC DRW D/A flatbed

rutzbeck

Haines, AK

Full Member

Joined: 08/13/2009

View Profile





Offline
Posted: 10/21/21 02:39pm Link  |  Quote  |  Print  |  Notify Moderator

I'll try it. I know I have at least one of those.
Thank you

EricCO

Colorado

Senior Member

Joined: 04/16/2007

View Profile



Good Sam RV Club Member

Offline
Posted: 10/21/21 03:12pm Link  |  Quote  |  Print  |  Notify Moderator

If it shows up again, try swapping the motors around to help isolate the problem.

You mentioned in one of the posts that the motor is older so it might be time to replace it.


2002 Ford F-350 CC LB PSD
2007 Travel Lite 960rx Ultra
2009 Lund 208 Pro-V GL with 250 hp Verado


Reply to Topic  |  Subscribe  |  Print Topic  |  Post New Topic  | 
Page of 2  
Next

Open Roads Forum  >  Truck Campers

 > Jack Misbehaving
Search:   Advanced Search

Search only in Truck Campers


New posts No new posts
Closed, new posts Closed, no new posts
Moved, new posts Moved, no new posts

Adjust text size:




© 2021 CWI, Inc. © 2021 Good Sam Enterprises, LLC. All Rights Reserved.